Issue with sim manipulator

View previous topic View next topic Go down

Issue with sim manipulator

Post  Essa on Fri Mar 04, 2016 7:09 am

Hi,
I'm using Sim manipulator since I've heard about it and I think it's a great tool.
I especially like the "motives" features.
Yesterday while I was playtesting CC, I got a jump bug while using "Motives > 25% > all sim on lot. Here's the log error file.
Lowering social (25%) on one sim only works as intended though.

Thanks in advance.

Essa
Site Member


Back to top Go down

Re: Issue with sim manipulator

Post  Aaroneous on Fri Mar 04, 2016 11:10 am

So if I am understanding this properly when You change the motives of a single sim everything works as intended, But if You try and change the motives of all sims You get an error. Does that sound about right? In the mean time I will look over that code and see if anything is amiss.

Also the jump bug is how the game handles errors in the game when not in testing mode. If You can get the error to happen while in testing mode the game would say what the error is, It will also generate a file in the logs folder that shows what was happening at the time of the error. To enter testing mode type "boolProp testingCheatsEnabled true" in the cheat window(preferably when You're at the neighborhood window). When the error happen a dialog window should appear and say a error happened. It should ask You what to do about the error. There should be options like reset, delete, and ignore. Choose reset, In most cases that should work.

Finally In the same dialog it should say the name of the file the error was saved to. It should be something like this ObjectError_N001_t824150.txt, I won't be exactly like that but it should similar. If You can get that file and upload it here, That would greatly help in figuring out what's happening with the Sim Manipulator and Your game. You should be able to upload files in this section of the forum.
avatar
Aaroneous
Admin


Back to top Go down

Re: Issue with sim manipulator

Post  Essa on Sat Mar 05, 2016 2:46 pm

I only got the error when using "Motives < social < all sims on lot".

Here's the error log again. It seems I didn't succeed to attach it here at my first try.
Attachments
ObjectError_N003_t57524.txt You don't have permission to download attachments.(76 Kb) Downloaded 2 times

Essa
Site Member


Back to top Go down

Re: Issue with sim manipulator

Post  Aaroneous on Sat Mar 05, 2016 4:40 pm

Thanks for the file, Essa. It very much helped narrow down the error. It appears it is a bug in the current version of the Sim Manipulator, I was able to replicate the issue several times. From looking over the log and me replicating the issue it appears the bug is only present in the social menu(clicking on a sim)version of editing the motives(only for the social need with setting it for all sims on lot). Editing the social need from the Sim Manipulator works as advertised.

I am currently tracking down what is causing the issue, But I hope to have a fix released in the near future.
avatar
Aaroneous
Admin


Back to top Go down

Re: Issue with sim manipulator

Post  Essa on Wed Mar 09, 2016 7:02 am

Good to know.
Thanks

Essa
Site Member


Back to top Go down

Re: Issue with sim manipulator

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum